Page 1 of 1

[solved] Linux: getting errors and can't connect to devices

PostPosted: Wed Oct 28, 2015 9:13 am
by epileftric
I'm still getting this error message in the console:

Code: Select all
sr: ezusb: Unable to set configuration: LIBUSB_ERROR_OTHER
[...]
sr: Firmware upload was not needed.
sr: Unable to get version info: LIBUSB_ERROR_TIMEOUT.
sr: Failed to get firmware version.
sr: Unable to open device.


And I can't get anything from any of the devices. They both work, I've tested them on Windows and work just fine. There's no problem with the user access, I get the same error when running with root user. I think this is more related to the libusb.

Any help please? It's been two weeks since I got the equipment and can't use them properly.

_______________


Nevermind, I just recompiled every dependency for the Nth time and it worked this time, both in my laptop and in my desktop!

Re: Linux: getting errors and can't connect to devices

PostPosted: Thu Oct 29, 2015 12:50 am
by Andy
Hi,

When you compile the source, is there any issues?
Please using lsusb command to check the device is recognized normally.
What's the version of libusb you used to compile?

Thanks.

Re: Linux: getting errors and can't connect to devices

PostPosted: Thu Oct 29, 2015 2:00 am
by epileftric
As I said in the other thread I created (in the wrong section):

Code: Select all
< epilef@WarpOut:~ > $ lsusb
Bus 004 Device 003: ID 2a0e:0001


I'm building with the script Anatol created for the Arch linux user repositories (AUR) (link)

And building against libusb 1.0.20-1
____________


Solved. Recompiled everything, even all de dependencies and it worked THIS time... I don't know what was actually the problem.