[Solved] Can't connect to any of the devices

Topics about DSLogic software development
I get them listed by the SO like this: (both of them)

Code: Select all
< epilef@WarpOut:~ > $ lsusb
Bus 004 Device 003: ID 2a0e:0001 


Then when I start the DSView I get this messages:

Code: Select all
sr: Sanity-checking all drivers.
sr: Sanity-checking all input modules.
sr: Sanity-checking all output modules.
sr: hwdriver: Initializing driver 'demo'.
sr: hwdriver: Initializing driver 'DSLogic'.
sr: hwdriver: Initializing driver 'DSCope'.
sr: hwdriver: Scan of 'demo' found 1 devices.
sr: ezusb: uploading firmware to device on 4.4
sr: ezusb: Unable to set configuration: LIBUSB_ERROR_OTHER
sr: Firmware upload failed for device 0.
sr: hwdriver: Scan of 'DSLogic' found 1 devices.
sr: hwdriver: Scan of 'DSCope' found 0 devices.
DreamSourceLab Hardware Attaced!
Protocol decoder enabled!
sr: Firmware upload was not needed.
sr: Unable to get version info: LIBUSB_ERROR_TIMEOUT.
sr: Failed to get firmware version.
sr: Unable to open device.


And then when I play Start I get an error dialog that says "Failed to start session". I downloaded and recompiled the DSview and Sigrok libs earlier today

________________

Marked as solved since updating packages and recompiling the program fixed this problem.
Last edited by epileftric on Tue Nov 03, 2015 9:14 am, edited 1 time in total.
epileftric
 
Posts: 10
Joined: Sun Aug 16, 2015 3:55 am

Sounds like a permission problem. Try to run application as sudo and see if it makes the difference.

Are you installing from Linux Arch AUR? The AUR package installs udev rules for root-less access to the USB devices. Just in case reboot your computer after AUR installation to make sure that udev rules are applied.
anatolik
 
Posts: 13
Joined: Wed May 20, 2015 4:02 am

I did try that earlier, still the same results. I tried also running sigrok client and get the same error, so I think this might narrow the options:

Code: Select all
< epilef@WarpOut:~ > $ sigrok-cli --scan
sr: fx2lafw: Failed to get manufacturer string descriptor: LIBUSB_ERROR_TIMEOUT.
The following devices were found:
demo - Demo device with 12 channels: D0 D1 D2 D3 D4 D5 D6 D7 A0 A1 A2 A3


What usb libraries do you have installed in your system? It's just a hunch, but I think is somehow a libusb* related issue. How does the devices identify in your computer after a lsusb
epileftric
 
Posts: 10
Joined: Sun Aug 16, 2015 3:55 am


Return to DSLogic Software

Who is online
Users browsing this forum: No registered users and 1 guest