DSView 0.96 linux - not working

Topics about DSLogic software development
DSView 0.96 is not working on my linux machine. I've tried it with both gcc 4.9 and 5 with the same result.

The software compiles fine, detects the DSLogic fine and starts fine; udev takes care of the device permission
and I can start a capture; LED goes green and the circle on the screen rotates up to 100% and then everything
stalls and no traces are displayed. I cannot stop/pause the acquisition but the GUI application is still responsive.
When I try to close the program the main window closes but the application is still running. The only way to stop
it is by killing the process. Demo device works fine though. My linux machine is an up-to-date Debian/testing.

I know that the logic analyzer itself works because on windows there are no such problems with the same
software version 0.96.

If anyone is interested here is a strace log until I kill the process: http://nic.ath.cx/DSView-strace.txt.gz
Where should I start looking to fix this problem?

Is anyone successfully running DSView 0.96 on linux?
Posts: 3
Joined: Wed Sep 10, 2014 11:07 pm


Yes, DSlogic runs on debian 8 stable.

You have a new Version see here


A problem by libusb.
Posts: 14
Joined: Thu Nov 19, 2015 1:33 am

Thanks for the link. With this patch now everything works fine.

I hope this software is still maintained and we'll see it reach at least version 1.00 ;)
libsigrok4DSL patch
(538 Bytes) Downloaded 64 times
Posts: 3
Joined: Wed Sep 10, 2014 11:07 pm

Return to DSLogic Software

Who is online
Users browsing this forum: No registered users and 1 guest