Page 1 of 1

binaries please

PostPosted: Thu Dec 25, 2014 8:26 pm
by Macsimski
Hello all,

Is it possible to make binaries for debian? I'm unable to make from source:

Code: Select all
../../libsigrok.h:156:77: warning: ‘struct sr_dev_inst’ declared inside parameter list [enabled by default]
 typedef int (*sr_receive_data_callback_t)(int fd, int revents, const struct sr_dev_inst *sdi);


this is the 0.4 version downloaded last week

Re: binaries please

PostPosted: Wed Dec 31, 2014 3:23 pm
by Andy
Is there any methods to make binaries for different Linux distribution?
Or we must make different binaries for different distribution?

Thanks.

Re: binaries please

PostPosted: Sat Jan 10, 2015 9:28 pm
by Macsimski
I have no knowledge on that topic, but a friend of mine suggested https://build.opensuse.org/ there must be other services as well.

Re: binaries please

PostPosted: Sun Jan 11, 2015 6:26 pm
by Rainer
Normally when you do a static compilation where you include all dependent libraries it should run on nearly all linux versions with the same architecture like x86.

Re: binaries please

PostPosted: Thu Jan 22, 2015 11:25 pm
by Macsimski
could you post a static compiled binary for i386 and amd64? i can test if they work. as the binary has to talk to the usb port, a separate udev rule should be made, but then we're set. :-)

Re: binaries please

PostPosted: Mon Jan 26, 2015 9:47 pm
by Rainer
The warning about "struct sr_dev_inst" should be no problem. I tried to compile it myself and also got these warnings but it doesn't stop the compiler. Because of the many dependencies i have no clue how to compile it statically. :?
But at least it compiles through and runs after that. So just try it again and don't be concerned about the warnings. ;)

Re: binaries please

PostPosted: Sun Mar 01, 2015 1:09 am
by Macsimski
Hello all.

I'm a little further after i've reinstalled ubuntu 14.04 from scratch so libsigrok4DSlogic, libusbx and libsigrokdecode are compiled now, although libsigrokdecode complained about python, unable to locate my python-3.4.0

we tried so many things i ca't remember what worked. sorry

BUT now i stuble upon a problem when compiling DSLogic-gui. cmake is unable to find libboost-system and i've found out that there is no libboost-system in the default location as Ubuntu 14.04 puts something with that name here:

/usr/share/lintian/overrides/libboost-system1.54.0
/usr/share/lintian/overrides/libboost-system1.55.0

I have no idea how to fix that.